Webnet Official Host Server is DOWN

Incident Report for Webnet Official

Resolved

Webnet Official Host Server is back UP
Posted May 03, 2026 - 13:20 PKT

Investigating

Webnet Official Host Server detected DOWN
Posted Apr 29, 2026 - 16:44 PKT