Webnet Official Host Server is DOWN

Incident Report for Webnet Official

Resolved

Webnet Official Host Server is back UP
Posted Apr 26, 2026 - 12:03 PKT

Investigating

Webnet Official Host Server detected DOWN
Posted Apr 25, 2026 - 17:39 PKT